Important - These requirements apply to the latest version of Fresh Store Builder v7.3.2. For previous versions, please see the Common Questions section below.

Requirements

To install Fresh Store Builder on your own server or website hosting, the following is required.

Server Setup and Technology

  • Operating System: Linux or Unix
  • Web Server: Apache (or comparable)
  • PHP Version 7.1 
  • MySQL Version 4, MySQL Version 5 and above

PHP Modules Required

  • IonCube Loader
  • GD Image Library
  • Imagick
  • MySQLi
  • XMLReader
  • mbstring

Common Questions and Problems

How do I know my server or web host is ready for Fresh Store Builder?

You can either ask your hosting support and show them this document, or when you install the script it will check and tell you what needs changing.

How can I change my PHP version?
Sometimes this can be done inside your cPanel. Please note if you change the PHP version it may affect other websites on your account.

You can also ask your hosting support to change the PHP version.

How can I add a PHP Module?
This can sometimes be done inside your cPanel. Your hosting support will be able to advise or make the change for you.

What about previous versions of Fresh Store Builder?
Previous versions to 7.3.2 do not support PHP7.1 and require PHP 5.3, 5.4 or 5.5.

Did this answer your question?